Cisco France Blog
Partager

J’ai testé pour vous – Les interface templates – ou comment simplifier la configuration de ses switchs


6 July 2014


La dernière release convergée sur nos switchs d’accès (2960-S / 2960-X / 3k-X / 3650 / 3850 / 4500 sup 7 et 8 / switchs industriels IE, switchs compacts…) apporte de nombreuses fonctionnalités. Je vous ferai un topo sur ce blog d’ici peu mais d’ici la vous pouvez jeter un coup d’oeil aux release notes dispos ici par exemple pour le catalyst 3850.

Parmi toutes ces nouvelles fonctionnalités la release IOS-XE 3.6E (ou 15.2(2)E en IOS classique) intègre plusieurs nouveautés pour simplifier le réseau (déploiement et opération). L’une d’entre elle est assez basique mais devrait vous plaire: les interface templates. L’idée est simple: on créé des templates de configuration et on peut les appliquer ensuite sur les ports. On reprend l’idée des port profiles sur les switchs Nexus pour le datacenter. J’ai pu rapidement tester et vous ai documenté cela dans la suite de cet article.

Matériel utilisé:

Catalyst 3850 (notez bien que la fonction est supportée sur les autres commutateurs d’accès également)

IOS utilisé:

IOS-XE 3.6E – fichier cat3k_caa-universalk9.SPA.03.06.00.E.152-2.E.bin

Déroulé du test:

Je pars d’un design simplissime sur mon switch d’accès avec plusieurs ports configurés de la même façon… 2 sont représentés ici mais on imagine la taille pour un switch 48 ports.

interface GigabitEthernet1/0/8
description PORT vers IP Phone et ordinateur
switchport access vlan 2000
switchport mode access
switchport voice vlan 3000
spanning-tree portfast
service-policy output EasyQos-Egress
!
interface GigabitEthernet1/0/9
description PORT vers IP Phone et ordinateur
switchport access vlan 2000
switchport mode access
switchport voice vlan 3000
spanning-tree portfast
service-policy output EasyQos-Egress

L’objectif des interface templates est de simplifier tout cela… Je commence par repartir d’une configuration vierge sur les ports que je vais utiliser dans ce test (1/0/8 – 11)

c3850-1(config)#default interface range gi 1/0/8-11

Je définis ensuite mon template

template TOIP-DESKTOP
 switchport access vlan 2000
 switchport mode access
 switchport voice vlan 3000
 spanning-tree portfast
 service-policy output EasyQos-Egress
 description PORT vers IP Phone et ordinateur

Et enuite j’applique mon template sur les ports en question

c3850-1(config)#int range gi 1/0/8-11
c3850-1(config-if-range)#source template TOIP-DESKTOP

Ma running-configuration se retrouve largement simplifiée

interface GigabitEthernet1/0/8
 source template TOIP-DESKTOP
!
interface GigabitEthernet1/0/9
 source template TOIP-DESKTOP
!
interface GigabitEthernet1/0/10
 source template TOIP-DESKTOP
!
interface GigabitEthernet1/0/11
 source template TOIP-DESKTOP

Pour voir la configuration complète il faut regarder la derived-configuration

c3850-1#sh derived-config | b 1/0/8
interface GigabitEthernet1/0/8
 description PORT vers IP Phone et ordinateur
 switchport access vlan 2000
 switchport mode access
 switchport voice vlan 3000
 spanning-tree portfast
 service-policy output EasyQos-Egress
!
interface GigabitEthernet1/0/9
 description PORT vers IP Phone et ordinateur
 switchport access vlan 2000
 switchport mode access
 switchport voice vlan 3000
 spanning-tree portfast
 service-policy output EasyQos-Egress

(je n’affiche que 2 interfaces mais vous aurez compris le principe…)

Imaginons que je doive faire une modification du template, cette dernière est immédiatement appliquée sur tous les ports.

c3850-1(config)#template TOIP-DESKTOP
c3850-1(config-template)#switchport voice vlan 3001

c3850-1(config-template)#do sh der | b 1/0/8
interface GigabitEthernet1/0/8
 description PORT vers IP Phone et ordinateur
 switchport access vlan 2000
 switchport mode access
 switchport voice vlan 3001
 spanning-tree portfast
 service-policy output EasyQos-Egress
!
interface GigabitEthernet1/0/9
 description PORT vers IP Phone et ordinateur
 switchport access vlan 2001
 switchport mode access
 switchport voice vlan 3001
 spanning-tree portfast
 service-policy output EasyQos-Egress

J’arrête ici pour cet article. Je pense que vous aimerez cette fonctionnalité et qu’elle sera rapidement une des plus déployée sur nos switchs. Notez que nous avons aussi avec cette nouvelle release une fonction autoconf qui va automatiquement appliquer les templates au bon endroit en fonction du type de device connecté (vous pouvez voir cela comme une extension d’auto smartports pour s’adapter aux interface templates). On a également auto-secure pour rajouter en une ligne de commande toutes les configurations de sécurité que l’on recommande (DHCP snooping, dynamic ARP inspection, port security…) On en reparle prochainement.

Je profite de cet article pour souhaiter à toutes et tous d’excellentes vacances. Nul doute que nos efforts de simplification vous permettront d’en profiter davantage 🙂

Références

Guide de configuration des interface templates

@JeromeDurand

Tags:
Laisser un commentaire

2 commentaires

  1. Bonjour,
    Y aura-t-il une sortie de la version 15.2.2 pour les switchs plus anciens (2960 première génération, 3750, …) ?
    Cordialement,

    • De mémoire la 15.0(2)SE doit être le dernier IOS (extended maintenance) pour ces plateformes.