Cisco France Blog
Share

Prime Infrastructure 1.2.1 et LMS 4.2.3 sont disponibles

- 28 December 2012

Quelques jours avant Noel, Cisco a mis à disposition Prime Infrastructure 1.2.1 et Prime LMS 4.2.3. Ces deux versions étaient attendues depuis plusieurs mois, et ce retard mérite quelques explications.

Dans mon premier billet sur Prime Infrastructure, je vous avais parlé d’une version 1.2.1 après l’été (2012… 🙂 ) et d’une version 2.0 en cette fin d’année. Ce planning a été modifié pour au moins deux raisons:

  • De nombreux problèmes de migration de NCS (toutes versions) vers PI 1.2 nécessitaient une résolution prioritaire. Ces problèmes ont fait l’objet début décembre d’une “Field Notice” disponible ici.
  • Il a été décidé de ne pas mettre de nouvelle fonctionnalité dans les releases “sous-mineures” de Prime Infrastructure (1.2.1 par rapport à 1.2) et d’utiliser ces versions uniquement pour des correctifs. Personnellement, je pense que c’est une sage décision … On croit bien faire en mettant dans la release X.Y.Z+1 ce qu’on n’a pas le temps de finir pour la release X.Y, et quelques mois ou trimestres plus tard, on en découvre les conséquences en terme de migration et de support …. (Je suis assez vieux pour avoir connu cela du coté engineering dans plusieurs vies antérieures à Cisco 🙂 )

Cette version 1.2.1 ne contient donc aucune nouvelle fonction. En particulier, le module de gestion de la conformité est reporté à une version ultérieure. Les problèmes corrigés, ainsi que les problèmes restants sont documentés dans les releases notes. Prime Infrastructure 1.2.1 est compatible avec la release wireless  7.4, mais ne permet pas d’administrer les nouveautés de WLC 7.4. Il faudra pour cela attendre Prime Infrastructure 1.3 prévue fin Janvier 2013. Cette version 1.3 n’était pas prévue initialement, mais a été décidée pour assurer la meilleure synchronisation possible avec la roadmap des produits Wireless. (C’est pas parfait, mais ça limite l’attente ….). La version 2.0 de Prime Infrastructure est reportée à une date non encore fixée durant la première moitié de l’année 2013.

Au vu des problèmes corrigés (qui ne sont pas tous documentés …) et du temps supplémentaire alloué uniquement à améliorer la robustesse du produit, je recommande fortement à tous les utilisateurs de NCS et PI 1.2 de passer sans tarder à Prime Infrastructure 1.2.1. Les utilisateurs de Prime LMS qui se demandent quoi faire liront attentivement ces deux billets (“différences entre PI et LMS” et “stratégies de migration vers PI“) avant de se jeter à l’eau :)…. Et je rappelle également que la license (au sens “droit d’usage”) de LMS est incluse avec Prime Infrastructure, comme mentionné dans ce billet et dans l‘ordering guide de Prime Infrastructure.

Comme précédemment, la version 1.2.1 est disponible au téléchargement sous plusieurs formats: une image ISO pour les boitiers physiques (appliance), et quatre images OVA (small, medium, large et extra-large) pour VMware, selon le nombre d’équipements à superviser. Pour savoir quelle taille d’image OVA choisir, reportez-vous à la fiche produit.

Pour les upgrade depuis NCS (toutes versions) ou PI 1.2, il est nécessaire de procéder en deux temps, comme expliqué dans le guide d’installation:

  1. installation d’un patch qui est différent selon la version actuelle de NCS ou PI 1.2 (détails ici)
  2. installation du package d’upgrade.

Concernant LMS 4.2.3, cette version apporte uniquement des corrections, dont la liste est donnée dans les release notes. Comme annoncé précédemment, il n’y aura plus d’évolution fonctionnelle de Prime LMS.

Tags:
Laisser un commentaire

Share